Skip to content

There are several, quite huge fuckups which causes that Android Auto should still be considered as a toy, not a real and useful application.

These includes:

  • "Contacts" tab doesn't recognize non-standard phone numbers' labels. If you have a contact with many customly-named phone numbers (i.e. "Gate", "Hospital" etc.) you will see "Custom" for all of them, instead of real names, and you must remember / guess which exactly phone number you were about to call.
  • "Contacts" tab includes everything mixed up. In a one place, on a single list there's everything -- your starred / favourite contacts, your recent calls and all contacts from your address book. Finding anything in this mess is a nightmare, especially if you have to focus on driving your car in the same time. Each and every address book (including default, system one in Android) has such list split into three sections -- favourite, recent and all. Android Auto -- where driving safety and using touch screen in a minimal manner is key -- is the only weird exception.
  • Android Auto fails completely on screen locks. As long as you don't unlock your phone, Android Auto will always start on the phone only. If you want to see and use in in your car's multimedia system, you are forced to unlock your phone's screen each time you connect your phone to your car with an USB cable.

The additional problem is a communication between car and a phone. Regular multimedia systems are using Bluetooth for this purpose. In case of Android Auto you must use USB cable instead. Bluetooth is used also, for some weird reason. And Android Auto blocks it!

If you fail upon third above (i.e. not unlock your phone's screen and having Android Auto on your phone only) you won't be able to communicate with your phone, using your car's multimedia system, in any way. Android Auto will be unavailable due to not unlocked phone's screen. And car's application won't be available due Bluetooth blocked by Android Auto and no communication with your phone.

I wanted to report above problem, as I did with three earlied, but I was blocked from doing so, because Google Help said that for some weird reasons my post violates Google policy.

I have created a number of posts in Android Auto Community. All technical, all about same or similar problems. When I wanted to post fourth, I was hit with this:

I\'ve read this damn post seven times and found nothing that could violate that stupid Google Help\'s policy. Any idea what am I missing?

This site is currently in import mode. I'm importing all my posts from external sources. Anything strange may happen here, until this process is over (and this notice is removed).

Posts import in progress...